UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Sat Apr 29, 2017 5:38 am

All times are UTC




UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sun Jan 31, 2016 10:12 am 
Offline
New UberStudent User

Joined: Sun Jan 31, 2016 9:49 am
Posts: 6
Hello
After trying 4 times to install UberStudent 4.3, failing each time, I tried installing the 4.1 version, with the same success. I mention that I have some experience with installing Linux distros. I currently have multiple Linux systems on my computer - a few Ubuntu and Ubuntu-derived OS, Manjaro, Chakra and Fedora. So, I cannot figure out what is wrong with UberStudent. The installation is progressing till the grub-installation part, where it gives me an error.
Being an Ubuntu-based, distro, I expected no such problems.
I don't have any problems in the live session - the system runs smooth, without errors. I used the Ubuntu usb creator for the usb stick installation - can this be the problem?
I have an Asus N56VB laptop, with IvyBridge i7 processor.


Top
 Profile  
 

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!

PostPosted: Sun Jan 31, 2016 4:58 pm 
Offline
Established UberStudent User

Joined: Fri Sep 25, 2015 3:10 am
Posts: 29
Location: USA
You should ensure the file wasn't corrupted during the install by checking the .iso file against the md5 sums on Sourceforge.

http://sourceforge.net/projects/uberstu ... eraclitus/

_________________
Go Live Lively


Top
 Profile  
 
PostPosted: Mon Feb 01, 2016 9:12 am 
Offline
New UberStudent User

Joined: Sun Jan 31, 2016 9:49 am
Posts: 6
Jacqueem Spratley wrote:
You should ensure the file wasn't corrupted during the install by checking the .iso file against the md5 sums on Sourceforge.

http://sourceforge.net/projects/uberstu ... eraclitus/


I checked the md5 sums and it's ok. Any other ideas?


Top
 Profile  
 
PostPosted: Mon Feb 01, 2016 10:32 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 937
Location: UberStudent Headquarters
Thank you for taking the time to report this issue.

Following the hints about your laptop model and that the installer failed for you while installing grub, as well as that this issue was not simply a corrupt installation medium as determined by an MD5 sum check, I was able to replicate the issue in a UEFI installation. The issue is now fixed.

Explanation:

When installing UEFI grub, the installer failed due to a broken dependency. Here are the relevant log file snippets indicating so:
Code:
Feb  1 03:07:38 uberstudent ubiquity: Some packages could not be installed. This may mean that you have
Feb  1 03:07:38 uberstudent ubiquity: requested an impossible situation or if you are using the unstable
Feb  1 03:07:38 uberstudent ubiquity: distribution that some required packages have not yet been created
Feb  1 03:07:38 uberstudent ubiquity: or been moved out of Incoming.
Feb  1 03:07:38 uberstudent ubiquity: The following information may help to resolve the situation:
Feb  1 03:07:38 uberstudent ubiquity:
Feb  1 01:30:30 uberstudent ubiquity: The following packages have unmet dependencies:
Feb  1 01:30:30 uberstudent ubiquity:  grub-efi-amd64-signed : Depends: grub-efi-amd64 (= 2.02~beta2-9ubuntu1.7)
Feb  1 01:30:30 uberstudent ubiquity: E
Feb  1 01:30:30 uberstudent ubiquity: Unable to correct problems, you have held broken packages.
[...]
Feb  1 03:07:43 uberstudent grub-installer: info: Calling 'apt-install grub-efi-amd64-signed' failed
The reason for the breakage is that the Ubuntu trusty-updates repository currently has a package of grub-efi-amd64-signed that is missing its required dependencies. One can know this because, for example, we do not see version 2.02~beta2-9ubuntu1.7 of the package grub-efi-amd64 in the below list, which is named above as missing; nor is the missing package in any of the other Ubuntu repositories for trusty:
Attachment:
Screenshot_2016-02-01_01-46-05.png
Screenshot_2016-02-01_01-46-05.png [ 105.55 KiB | Viewed 5625 times ]
I fixed the issue by simply adding the missing grub packages into the uberstudent.net repository from the Ubuntu trusty-proposed repository. Your UberStudent installation will now succeed because the version-corresponding grub packages in the uberstudent.net repository will override the broken grub packages in the Ubuntu repository. This applies to all UberStudent installations in the 4.* series.

I'm guessing that a lot of distros in the Ubuntu ecosystem are currently facing this same issue--Google will help them find this post. Thanks very much for reporting this bug to me so I could quickly issue a fix. :geek:

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Mon Feb 01, 2016 1:30 pm 
Offline
New UberStudent User

Joined: Sun Jan 31, 2016 9:49 am
Posts: 6
It's great that you got the solution to this problem so quickly. And thanks for the prompt reply.


Top
 Profile  
 
PostPosted: Tue Feb 02, 2016 8:26 pm 
Offline
New UberStudent User

Joined: Sun Jan 31, 2016 9:49 am
Posts: 6
...and I installed the system without a problem.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!



All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group