UberStudent Forums

"Failed to send D-Bus message" error on boot up
Page 1 of 2

Author:  Dinesh Damodaran [ Sun Dec 07, 2014 3:13 pm ]
Post subject:  "Failed to send D-Bus message" error on boot up

Hi Stephen,

I am getting a "Failed to send D-Bus message" error every time I boot into UberStudent Epicurus.

The detailed message below this error is as follows

"Did not receive a reply. Possible causes include: the remote application did not send any reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

This dialog box takes a whole 20 odd seconds to pop up and after it pops up it take another 10 odd seconds before I can close it. Only after closing it am I able to use the laptop (clicking and opening the menu / applications etc).

The context menu also seems to get activated once the dialog box closes. Hope this information helps in resolving it.



Author:  Stephen Ewen [ Mon Dec 08, 2014 11:26 am ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

I understand from your post that this is a minor annoyance. Since I cannot replicate this annoyance on any of my machines, please give me more time to look in to it.

Overall, the UberStudent 4.1 desktop will take a few seconds longer to be active, by default. Any clicks will be ignored until then. This is because the Applications menu file is now being pre-loaded at boot-up to work around an upstream Xfce issue that causes the menu to not immediately load when first clicked. After the menu pre-loads, the desktop becomes fully active. I basically chose to trade a larger minor annoyance (i.e., a menu that does load when you first click it) for a lesser minor annoyance (i.e., a menu file that is ready-to-go when you first click it at the expense of a slightly longer boot time).

This should have absolutely zero bearing on dbus; however, it's possible that I can change the timing of the menu file pre-loading by literally a second or two to avoid this dbus annoyance.

Author:  Dinesh Damodaran [ Mon Dec 08, 2014 11:30 am ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up


I am just reporting the bug. Feel free to fix it as per your convenience.

Warm Regards


Author:  Stephen Ewen [ Mon Dec 08, 2014 9:27 pm ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

Let's try this:

Please go to Setting menu > Session and Startup > Advanced ... and tick the box for Launch GNOME services on startup. Then, log out and log back in.

Any change?

Author:  Dinesh Damodaran [ Mon Dec 08, 2014 10:29 pm ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

Hi Stephen,

I tried the fix you suggested, but still getting the D-bus error. Just to clarify, since you asked me to log out and log in, I get this error only when I do a proper boot / restart, it does not occur during log out and log back in.



Author:  Stephen Ewen [ Tue Dec 09, 2014 1:09 am ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

Let's see if menu pre-leoading is mistimed. Please take the following steps.

Hit Alt+F2 on your keyboard and run the following line:

gksu geany /etc/xdg/xdg-uberstudent/autostart/xfce4-popup-applicationsmenu.desktop

On line 5, comment out the line by adding a # before it so the line looks like the following:

#Exec=sh -c "sleep 15; xfce4-popup-applicationsmenu;" &&

Save the file and reboot.

If you still get the error, please revert the changes you just made.

As for these next steps, I realize it is fair amount of work for a minor annoyance, but this is the only way I can gather the info I need to understand and perhaps fix the problem. So if you wish, please take the following steps. What we will be doing is setting up a temporary situation on your machine to log dbus actions while the error happens and write them to a file so you can share the result of that file with me. That way, I have the info I must have to see what's going on. The steps will be educational ;) and could help any other users experiencing this issue.

Here are the steps:

Copy the below code block to your clipboard, hit F12 on your keyboard, paste it in to guake terminal using Ctrl+Shift+V, and then run it by hitting Enter twice.

Creates an autorun for dbus-monitor
echo "[Desktop Entry]
Name=D-Bus Monitor
Comment=Monitor D-Bus
Exec=xterm -hold -e 'bash -c dbus-monitor | tee $HOME/Desktop/dbus-error.log'
Terminal=false" > $HOME/.config/autostart/dbus-monitor.desktop

Next, run the following code line:

Allows the desktop file to be executed
chmod 777 $HOME/.config/autostart/dbus-monitor.desktop

This is all very important so please print these directions out now and get a good handle on them before your next reboot, and follow them carefully during your next reboot:

Reboot your machine. A terminal window will open as soon as you reboot. It will be logging the output of dbus-message. Leave it be, let it do so.

The dbus error message dialog you originally posted about should then shortly display. When it does, as soon as you can, click to exit out of it. Then, as soon as you can, exit out of the dbus-message terminal window that opened at boot-up. Once you have exited out of both, you will then find a text file on your Desktop titled dbus-error.log. That's the info I need. Please attach that file to your next post, or copy and paste the contents of it in to your next post.

To stop dbus-monitor terminal from running again--to revert this temporary situation I've just had you create--simply run the following in a terminal, hitting Enter twice:

echo "Hidden=true
NoDisplay=true" >> $HOME/.config/autostart/dbus-monitor.desktop

Author:  Dinesh Damodaran [ Tue Dec 09, 2014 11:56 am ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

Hi Stephen,

The "#" fix worked. Thanks a lot.



PS: I wrote to you sometime back regarding a possible research paper. Never heard back, just wanted to check if you received the mail or not.

Author:  Stephen Ewen [ Tue Dec 09, 2014 6:10 pm ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

I just now searched my inbox and found the email. It somehow became buried, unopened. I've replied to you. ;)

So you can still benefit from menu pre-loading, you can try increasing the sleep time in the line, for example, Exec=sh -c "sleep 18; xfce4-popup-applicationsmenu;" &&

Author:  Kbouchard [ Mon Sep 21, 2015 6:54 pm ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up

Step 1 worked for me. Disabling the sleep that is. I had installed and checked the Gnome Keyring, and Activated the Gnome on startup in startup manager.
Those did not work, but I do not think there will be any reason to uncheck those. I guess it depends on if it somehow chooses to not remember passwords.
Is Uberstudent a Gnome based system it seems not since Thunar is the file manager, and xfce is the desktop.

Another discovery for those encountering odd issues. Xscreensaver requires you to go into Synaptic Package Manager and install all the additional Xscreen screen savers.
Also I disabled the "flow" screensaver because each time it launches, you get this annoying popup window that turns into several windows over a period of time IF you are doing random and/or sequential.

Another discovery is that if you use dual head video and 2 monitors, is that you have to right click to preferences, on each monitor, and you can change the random wallpaper settings. But they are unique for each monitor.

Monitor windows are NOT the same as workspaces. Consider workspaces as multiple desktops, or virtual monitors. Powerful when you plan to run background apps but dont want to see them all the time.

Author:  jeeprad [ Wed Dec 23, 2015 12:30 pm ]
Post subject:  Re: "Failed to send D-Bus message" error on boot up


First let me apologize for not posting under my real name. I would have given my real name if you included the option to post under a user name, but you don't have that option available. I only have one question, and I'm not likely to post here again; and I don't want my real name forever linked online to this one question.

That said, I am barely above "novice" Linux user, and I just installed UberStudent 4.1 32 bit on what was an old Win XP laptop, and upon every initial boot and subsequent restart, I still get the "Failed to send D-Bus message."

Since it is now a full year after the initial post in this thread, I was wondering if you ever intend to fix that via an update, or is it going to be left to the end user to fix?

I understand that part of your mission statement is to have users be Linux proficient, but I don't believe that they should have to fix something before they can even start using your distro; especially since the bug has been know for a year, and this is supposed to be ready "right out of the box."

That's really all I'd like to know at this point.
Thank you.

Page 1 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Group