UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Wed Oct 18, 2017 1:45 am

All times are UTC




UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Aug 04, 2014 9:53 pm 
Offline
Established UberStudent User

Joined: Sat Aug 02, 2014 11:13 am
Posts: 18
Hi,

I was trying to edit my application menu using MenuLibre / Menu Editor and in the process I lost all applications from "accessories" right up to "system"

I am unable to locate these when I use the application search option and the only way I am able to launch these missing applications is using run.

Is there any way to revert menu editor to a default state so I can get the applications back again? Let me know if I need to share any more information on this.


Thanks

Dinesh


Top
 Profile  
 
PostPosted: Tue Aug 05, 2014 5:34 am 
Online
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 950
Location: UberStudent Headquarters
Thanks very much for making me aware of this issue with menulibre.

It appears that the menulibre behavior you described is also described in Ubuntu bug #1315991. I was able to replicate the bug's behavior.

Since the bug has not yet been fixed in upstream menulibre, I have piggy-backed a fix in the UberStudent package uberstudent-appinstaller.

The fix is that menulibre will be removed and replaced by alacarte, which works without issue. A script will then run that will restore any menu that may have been broken by menulibre to the UberStudent default.

To apply the fix, simply run the Update Manager from the top-right UberStudent panel and this fix will be applied from within the package uberstudent-appinstaller. You can then run the application Main Menu (which will run alacarte) from the Settings menu and make your menu changes as desired.

Thanks again for making me aware of this issue. :geek:

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Tue Aug 05, 2014 7:52 am 
Offline
Established UberStudent User

Joined: Sat Aug 02, 2014 11:13 am
Posts: 18
Thanks Stephen,
:D
The Application menu gets restored when MenuLibre is uninstalled and alacarte installs in its place. No need to run the code. I was getting the following error when I did try to run the code.

Code:
rm: cannot remove ‘/home/dinesh/.local/share/applications/*.desktop’: No such file or directory


Also wanted to share the real reason I actually started tweaking the menu with menu libre in the first place.

Applications -> System -> Administration -> Resources -> The Linux Command Line returns the following error

Quote:
Failed to open "/usr/share/uberstudent/linux-commandline-reference/*.pdf".
Error when getting information for file '/usr/share/uberstudent/linux-commandline-reference/*.pdf': No such file or directory.


I navigated to this path manually and the directory and path exist as stated. So not sure what to do here exactly.

Regards

Dinesh


Top
 Profile  
 
PostPosted: Tue Aug 05, 2014 8:18 am 
Online
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 950
Location: UberStudent Headquarters
If you will run the Update Manager again the package uberstudent-systemhelp-xfce will update and fix the broken link to the The Linux Command Line resource. Apparently, the Xfce code base in UberStudent 4.0 does not read desktop file wildcards (*) within paths, as it did in 3.0. Regardless, it is fixed now. Just run the Update Manager.

Dinesh Damodaran wrote:
No need to run the code.

Yes, I removed said user-input code from my earlier post in this thread, because I ended up adding the code so it runs automatically within the package's post-installation script; so, simply updating will completely fix the issue without any user input. Update and...you're done!

The "No such file or directory" output you got is normal. It is an entirely expected message if your machine has fewer than ten user accounts. :geek:

Thanks again for taking the time to make UberStudent better by reporting behavior from it that you did not expect. :)

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Tue Aug 05, 2014 9:04 am 
Offline
Established UberStudent User

Joined: Sat Aug 02, 2014 11:13 am
Posts: 18
Thanks for the speedy resolution Stephen, you rock! :-D

I didn't realize you edited your response, so ran the code, you made the fix easier by including it in the update.

I am very happy to be associated with your Distro and the least i can do is report bugs. This is the first time I am using UberStudent and while all behaviour is unexpected, some of them pleasantly surprise me too.

Will report bugs and fixes (that exist on the other forums) as and when I come across them.

Thanks again for responding so quickly. Appreciate it!

Regard

Dinesh


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!



All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group